You need to log in to create posts and topics.

Users in a usergroup is not shown forum

Good day, asgaros. You are doing a great job. I have issues in the followings:

1. A user is a particular user group, attached to a forum category will not see that category while logged in, and sometime when he logs in, he sees the forum. What could be wrong?

2. Is there a way one can show all forum but upon clicking, if you are not meant to view the contents of the forum, you will be redirected to login page or registration page.

 

Thanks in anticipation for your responses

Hello @habeebkabeer

Issue 1 sounds like a caching-issue to me. Please disable caching-extensions for the page which contains your [forum]-shortcode.

Issue 2 cannot be solved at the moment. The reason is relatively simple: If users want to hide a forum from logged-out guests, the "last post"-area can still contain information about its contents inside. Thats why those forums are hidden to prevent that any internal data is leaked to the outside.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

Thank you very much, you are doing a wonderful job. How i wish i can mention in my forum, same way you mentioned my name

Hello @habeebkabeer

When you have the mentioning-functionality enabled, you can see a gray name below usernames (as in this forum). If you write this name and put the @-character in front of it, the user will get a mentioning-notification.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!