You need to log in to create posts and topics.

too big gap between post lines

Hi,

Another issue is too big gap between post lines. How to make it small (normal)?

My steps:

typing the first sentence -> Enter -> typing the second sentence -> Enter -> typing the third sentence, etc. -> Submit

 

"good" is what I want.

Thank you in advance.

 

And another question: how to make the word auto-transfer to another line entirely? Now the word is divided into two parts without any rules. There is no problem in Latin, but the problem in my native language.

For example, a word "Glückwunsch" (not in latin) would look after auto-transfer to another line:

Glückw

unsch

Update: if I take away the code you gave me here,  everything is OK.  So this issue is coming with the code.

 

Hello @bigworld

This is intended behavior of the WordPress core-editor. Pressing Enter adds a new paragraph. If you want to start a new line you have to press SHIFT + ENTER instead.

Regarding the word-break issue: I am not sure if I can fix this but I will have a look. Natural word-breaks are impossible because your browser does not know how word-breaks work for every language. Thats why they break words when there is no space. However, I will take a closer look.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

Thank you for a fast reply.

  1. If I use Shift+Enter there is the same big gap between lines. Please check it by yourself (your admin login & password are still available)
  2. Regarding the incorrect word breaking: the issue came with your code. I guess a browser is not in buisness. Take this code away, the problem disappears.

@bigworld The word-breaking is needed to break long words at the end of the post-container. Long links are basically considered as long words because there is no space between. Without it, the browser does not break the long link. But, if word-breaks are enabled, every word at the end of the post-container is getting broken as well. As a fallback you could use an url-shortener or insert the link via the link-button in the editor so you can assign the link to a text.

Regarding the spacing-issue: Can you make your forum available to the public so I can check it out? I cant sign into your page from China because Googles ReCaptcha is blocked here.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

@asgaros

I deactivated Google ReCaptcha so you can login.

@bigworld

Please try the following code:

#af-wrapper .post-message p {
    margin: 0 !important;
    padding: 0 !important;
}

If it does not work you should contact the developer of your theme because some theme-logic (maybe script) seems to add big paddings or margins to paragraphs and/or linebreaks. Maybe there is some option in the theme-settings to control this spacing.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

It does not work.

Finally I deleted the code you gave me to solve the word-break issue cause it obviously brought a big gap problem.

Now I still have the word-break issue. Your advice to use the short links is unconvenient because I cannot control the length of the links that users will include in their answers.

Test:  http://test-site.com/chart.php?key=YTo1OntpOjA7czoxOToiMTk3MC0wMS0wMSAwMDowMDowMCI7aToxO3M6MDoiIjtpOjI7czowOiIiO2k6MztzOjI6Il8xIjtpOjQ7czoxOiJmIjt9

There is the same issue if I put a long link into my answer here (see test above). Please use FireFox.

This is not a critical issue, but it needs to be solved in order to have a good forum view.

@bigworld

Yes, I will fix this issue with the next update to ensure that long links will not break the layout. I will come back to you as soon as I have a css-fix for you. 🙂

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!