Please or Register to create posts and topics.

Page error related to SEO setting

I'm setting up a new site, WP 5.5.3. All other plugins deactivated, no forum page yet, no threads, no SEO plugin installed, just a menu, a handful pages and Asgaros acitvated with some initial structure. I got this error message on top of most pages - astonishingly not on the main page, but on all subsequent pages:

Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 1 in /(...)/wp-includes/class-wp.php on line 223
Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 1 in /(...)/wp-includes/class-wp.php on line 224

To fix this error, I first have to deactivate "Search engine friendly URLs" in the Asgaros "URL & SEO" settings (the error still persists) and then change the theme, call some pages (and change back to my old theme). I tried it several times, activation of "Search engine friendly URLs" always triggers this error, no matter of "Slug" or "ID" settings. And it occurs with different themes, even Twenty-somethings.

Maybe this is related to the "SEO Problems" topic, maybe something else compromised my system (but I have no idea, didn't do anything special, it's very plain yet). I'm running Asgaros on other websites hosted by other providers without such problems, so perhaps (or most likely?) it's connected to some host-specific WP-Modifications (1und1). I can live with it anyway, because I just want an internal members forum invisible to search engines, but I guess you should know about.

Hello @ruewa

Does this problem still occur? Have you tried if re-saving the permalinks in the general WordPress-settings fix the problem?

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

Asgaros - I am getting the same exact errors.  I recently installed your forum and was having no issues, until I installed a plugin recommended in these support pages so I could add a new main menu item.  Once I installed "Toolbox for Asgaros Forum", I only added one menu item, then started getting the errors.  I deleted that menu item, still errors.  I deactivated and deleted "Toolbox for Asgaros Forum", but still errors.  I re-saved the permalinks in the general settings like you suggested... still getting errors.

I then deactivated Asgaros Forum as well.  Still errors!  Then I again went to Settings > Permalinks > Changed to Default > Saved, and No More Errors.  I then reactivated the Asgaros Forum (not Toolbox for Asgaros as it's still deleted), and errors came back. Saved Permalinks > still errors.

Repeated above (deactivate your forum > save permalinks > no errors, then reactivate your forum > errors > save permalinks > still errors)  Thanks!

Any suggestions?  I had to uninstall your forum, but until the problem occurred, I was really liking it.  Thanks!

Hey @azdolfan,

your problem could also be caused by caching. What kind of plugins are you using for caching?

What are your providers that you are using for your two websites?

Do you use any other plugins on this website and did you try to deactivate them to check if there is a conflict between them?

It would be also helpful if you can share your URL, so I can have a look.

If you ever wonder how to return the favour for helping you.

Same problen here. Deactivated Asgaros Forum and all is good.

Nothing to do / cache or other plugins

Hello -

I am working local, so unable to share a link.  I'm definitely sure caching was not an issue.  I cleared it frequently when setting it up and testing different colors.  I also tested it on other browsers, and the error followed.  I got rid of Asgaros completely after not being able to solve the issue, but I did reinstall it.  I've lost all my categories, etc.  This time I'm not going to add any categories, until I get the menus right.  I want to rid of the main header just for the forum page, but add a main site home menu item button to leave the forum, so I added that "Toolbox for Asgaros Forum" plugin.  I'm really surprised the Asgaros doesn't allow a simple menu option btw.  Maybe I will add the plugin again, to see if messes it up.  But, I have to do in a few days, because I need to finish something and back up site first.  I'll let you know how it goes.

Thanks!

If you have any plugin for caching, make sure that you deactivate it for the forum page. I've found other posts where this was causing exactly this kind of PHP warning.

For Caching it's also important to know that there are different kinds of caching. It's not only your browser that is caching a page, so it would not help to change the browser. There are also plugins that are caching your pages to reduce the workload of the server. And it can also be that the server is caching as well (e.g. Memcached).

If you are removing a plugin from the admin area it should always clean the database, that's why the categories are gone.

How did you set your Permalink structure?

If you ever wonder how to return the favour for helping you.