You need to log in to create posts and topics.

How can i desactive or delete Forum menu?

12

Hi, Great plugin sir, i have no problem with plugin, it,s work will and without any problem. I want to make some changes but not want to edit plugin file because i see you are working to make it more effectiv.

  1. How can i delete o desactive forum menu (screenshot1).
  2. How can i add a custom tittle in forum home page and a forum (this momento is home page "Forum", but the sub page of forum looking like the "My forum - Forum - My Site Name", for topic is "Some topic tittle - Forum - My Site Name"  very ver long tittle.
  3. I set in a Forum "Approval" for Approval needed (

Thanks.

Uploaded files:
  • Captura-de-pantalla-2019-05-20-a-las-14.35.16.png

Also want to informar you about some errors en Google Data Test Tool: https://search.google.com/structured-data/testing-tool?hl=es#url=https%3A%2F%2Fwww.asgaros.de%2Fsupport%2Ftopic%2Fusers-in-a-usergroup-is-not-shown-forum%2F

Gracias

Hello @adnan

You can hide the menu by adding the following code to Forum -> Appearance -> Custom CSS:

#forum-header {
display: none !important;
}

Modifying the page-title is currently not possible because titles are generated automatically to ensure best results in regards to SEO and structured content.

Regarding the approval-issue: Have you activated the approval-option for that forum in Forum -> Structure?

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!
Quote from Asgaros on May 20, 2019, 4:06 pm

Hello @adnan

You can hide the menu by adding the following code to Forum -> Appearance -> Custom CSS:

#forum-header {
display: none !important;
}
  1. #forum-header {
  2. display: none !important;
  3. }
#forum-header {
display: none !important;
}

Modifying the page-title is currently not possible because titles are generated automatically to ensure best results in regards to SEO and structured content.

Regarding the approval-issue: Have you activated the approval-option for that forum in Forum -> Structure?

  1. I already hide From header with CSS (looking for for any filter or function for delete it).
  2. SEO title if you add  option to add in Forum > Struture it,s best por SEO ¿why? See muy cruet Android Forum title is "Android - My Site Name"  but i can change it "Android Forum - My site name" is best.
  3. Yes i active approval option in forum in Forum -> Structure
Uploaded files:
  • Captura-de-pantalla-2019-05-20-a-las-16.34.01.png
  • Captura-de-pantalla-2019-05-20-a-las-16.34.40.png

@asgaros i am getting an other little problem "mysite. com/forum" only in home page of forum missing last "/" so the home page "mystic. com/forum" 301 to "mysite. com/forum/" all others page of forum working with last "/" with out problem.

Thanks!

For the menu there is currently no option available to completely disable it. As an alternative you can modify the showHeader() function inside of the asgaros-forum/includes/forum.php file and remove the logic for the menu.

I tried to reproduce the approval-issue with guest-postings enabled and its working fine for me. Please double-check if the non-loggedin user really created the topic inside of a forum which requires approval. Also keep in mind that currently approval is only available for new topics, but not for new posts.

Regarding the slash-issue: Can you check your WordPress permalink-settings in General -> Permalinks? Asgaros Forum usually uses the settings based on those permalinks. Maybe you have chosen a permalink-structure which has not a trailing slash at the end.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!
  1. For Menu i desactive all the sub-menu page and after i see only 1 link "forum" and i display: none;  so it,s Ok 🙂
  2. You are right, The new topic YES go to approval page but a new "Replay" publish with out admin review.
  3. I have last "/" in all the site, all de forum pages, topics , sub-forum but the only the home page of forum is with out last "/" (this forum have the same little problem. https://www.asgaros.de/support 301 to https://www.asgaros.de/support/

 

 

Uploaded files:
  • Captura-de-pantalla-2019-05-20-a-las-18.49.43.png

Hello @adnan

2: Approval for posts is not possible yet. Maybe I add this functionality in a future update.

3: I will check this issue and try to fix it in the next update.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

Ok thanks!! I edit language file (asgaros-forum.po) with Poedit and upload new "asgaros-forum-es_ES.po" and "asgaros-forum-es_ES.mo" but not seeing changes (my site is already set "Español" as a language). I want to change some words (no error) only in my site.

And the last think, there in any PHP function for get all user topics and posts? (replay), i have 3 others plugins with user perfil and i am making to use in single perfil page. So i am trying to get all user data in single page (i all ready change urls etc.. ).

Thanks a lot.

Hello @adnan

For translating-purposes I suggest you to use the following extension:

https://wordpress.org/plugins/loco-translate/

For getting all posts of a user I suggest you to use the following function:

global $asgarosforum;
$posts = $asgarosforum->profile->get_post_history_by_user($user_id, $limit = false);

 

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!
12