You need to log in to create posts and topics.

Extend shortcode to show specific content only

Hi @asgaros, I have trouble getting specific content to show and I hope you can help me.

Environment: WP 5.4.1 , Asgaros Forum 1.15.4 , other plugins including BuddyPress, Mikado Core, WPBakery Page Builder.

I've tried below shortcodes in a blank new page and in a blank new post but it will always show the entire forum index. So it's not that I keep seeing [forum] in the published page, but it will always show the forum index.

I read your explanation here about the content-area: https://www.asgaros.de/support/topic/extend-shortcode-to-show-specific-content-only/?part=4#postid-9199

AFAIK I placed these shortcodes in the content-area of the page/post. Not in some special area added by Mikado, or a widget or something. I tried using the visual editor and the text editor (the one that shows raw html). Unfortunately it gives the same result.

I also tried the 'backend editor' of WPbakery, same result. Then i added the shortcodes to the WPBakery settings shortcode mapper. The the shortcodes are recognized as elements in the backend editor. But still same result.

 

In summary, it appears that the [forum] shortcode is recognized, but that the attributes are not picked up. Then it shows the entire forum index view. Do you have an idea how to make this work?

 

[forum]

  // Note I also tried with single quotes and no quotes

[forum post="23"]

 

1 topic (1 thread):

[forum topic="1"]

 

1 (sub)forum:

[forum forum="25"]

 

 

 

Hello @alwin

Have you verified that you are really using the correct IDs - for example of the forum you want to show? Also ensure that you are not using the forum-shortcode two times at the same page.

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

Hi @asgaros Thanks for the quick reply!

"Also ensure that you are not using the forum-shortcode two times at the same page."

Thanks, this was the cause. Because I was testing I tried all possible shortcodes on 1 page, with a regular [forum] as the first use. That's why the entire forum index was repeated.

Would it be possible to add this to the start post https://www.asgaros.de/support/topic/extend-shortcode-to-show-specific-content-only/#postid-190 for future users?

 

 

Hey @alwin

I added a note to the first post. Thanks!

If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!